<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
<head>

<!-- BLOCK: uniform campus head  -->


<link rel="dns-prefetch" href="https://static.ucsc.edu"/>
<meta charset="UTF-8"/>
<meta content="IE=edge" http-equiv="X-UA-Compatible"/>
<meta content="width=device-width, user-scalable=yes, initial-scale=1.0, minimum-scale=1.0, maximum-scale=2.0" name="viewport"/>
<link href="https://www.ucsc.edu/favicon.ico" rel="shortcut icon"/>
<link href="https://www.ucsc.edu/apple-touch-icon.png" rel="apple-touch-icon"/>

<link href="https://static.ucsc.edu/_responsive/css/ucsc.css?t=20180412082400" rel="stylesheet" type="text/css"/>
<script src="https://static.ucsc.edu/_responsive/lib/modernizr/modernizr.js" type="text/javascript"></script>
<script src="https://static.ucsc.edu/_responsive/lib/jquery/dist/jquery.js" type="text/javascript"></script>
<script async="async" src="https://static.ucsc.edu/_responsive/js/main.js?t=20180409144600" type="text/javascript"></script>
<script defer="true" src="https://use.fontawesome.com/releases/v5.0.6/js/all.js"></script>

<!-- END BLOCK: included uniform campus head  -->

<title>Face recognition for galaxies: Artificial intelligence brings new tools to astronomy</title>

<meta content="Joel Primack, David Koo, VELA Simulations, CANDELS" name="keywords"/>




<link href="https://news.ucsc.edu/2018/04/deep-learning-galaxies.html" rel="canonical"/>

<meta content="Face recognition for galaxies: Artificial intelligence brings new tools to astronomy" property="og:title"/>
<meta content="https://news.ucsc.edu/2018/04/deep-learning-galaxies.html" property="og:url"/>
<meta content="A 'deep learning' algorithm trained on images from cosmological simulations has been surprisingly successful at classifying real galaxies in Hubble images." property="og:description"/>
<meta content="article" property="og:type"/>
<meta content="https://news.ucsc.edu/2018/04/images/galaxy-images-750.jpg" property="og:image"/>
<meta content="UC Santa Cruz News" property="og:site_name"/>
<meta content="1322847221,508316988" property="fb:admins"/>
<meta content="https://www.facebook.com/ucsantacruz" property="article:publisher"/>

<meta content="summary" name="twitter:card"/>
<meta content="@ucsc" name="twitter:site"/>
<meta content="https://news.ucsc.edu/2018/04/deep-learning-galaxies.html" name="twitter:url"/>
<meta content="Face recognition for galaxies: Artificial intelligence brings new tools to astronomy" name="twitter:title"/>
<meta content="A 'deep learning' algorithm trained on images from cosmological simulations has been surprisingly successful at classifying real galaxies in Hubble images." name="twitter:description"/>
<meta content="https://news.ucsc.edu/2018/04/images/galaxy-images-750.jpg" name="twitter:image"/>

      <meta content="Physical and Biological Sciences" name="category"/>
            
  
  
  
      <meta content="Astronomy and Astrophysics" name="category"/>
                <meta content="Physics" name="category"/>
            
  
      <meta content="Research" name="category"/>
            
  
      <meta content="Gifts and Grants" name="category"/>
                <meta content="Press Release" name="category"/>
            
      <meta content="Interdisciplinary" name="category"/>
            
      <meta content="Astro and Planets" name="category"/>
                <meta content="Silicon Valley" name="category"/>
            
      <meta content="Secondary Story" name="category"/>
            
      <meta content="Regular News" name="category"/>
            
  
  
  




</head>

<body class="left-column dept article">

<!-- Accessibility links. Hidden until they receive :focus -->
<ul id="access-links">
    <li><a href="#main">Skip to main content</a></li>
    <li><a href="#mainNav">Skip to main navigation</a></li>
</ul>



 <div id="wrap">
   <div id="container">
     <div id="content">
       

<div class="site-header" role="banner">

    <div class="page-top">
      <div class="row">

        <div class="page-top-left">
          <a class="campus-secondary" href="https://www.ucsc.edu/index.html" id="logo">UC Santa Cruz</a>
        </div>

        <div class="page-top-right">
          <ul id="topNav">
<li><a href="https://my.ucsc.edu" title="The student portal">MyUCSC</a></li>
<li><a href="https://www.ucsc.edu/tools/people.html" title="Campus directory">People</a></li>
<li><a href="https://www.ucsc.edu/tools/calendars.html" title="Upcoming events, academic, and administrative calendars">Calendars</a></li>
<li><a href="https://www.ucsc.edu/visit/maps-directions.html">Maps</a></li>
<li><a href="https://www.ucsc.edu/tools/azindex.html" title="A to Z index of UCSC websites">A-Z Index</a></li>
</ul>
          <div class="search" role="search">
            <!-- Google Custom Search --><form action="/search/" id="cse-search-box-site">
<div><input name="ie" type="hidden" value="UTF-8"/> <label class="hide" for="search-site">Search</label> <input class="query" id="search-site" name="q" placeholder="Search news" type="text"/> <input class="srchBtn" type="submit" value="Search"/></div>
</form><!-- end Google Custom Search -->
          </div>
        </div>

      </div>
    </div>

    <div class="main-header">

      <div class="row names">
        <div class="secondary-name">
          <h1><a href="../../index.html">Newscenter</a></h1>
          <a class="mobile-menu" href="#mainNav"></a>
        </div>
      </div>

      <div class="row main-navigation" role="navigation">
        <ul class="hasqsg" id="mainNav">
<li class="first" style="z-index: 0;"><a href="../../awards/index.html">Awards &amp; Honors</a></li>
<li style="z-index: 0;"><a href="https://events.ucsc.edu">Events</a></li>
<li><a href="../../video/index.html">Videos</a></li>
<li><a href="../../subscribe/index.html">Subscribe</a></li>
<li style="z-index: 0;"><a href="../../contacts-for-reporters.html">Contact Us</a></li>
<li class="last qsg"><span>Helpful Links</span> 
<ul>
<li><a href="../../categories.html">News by topic</a></li>
<li><a href="../../year-archive.html">News archives</a></li>
<li><a href="../../newsletter/index.html">E-Newsletter</a></li>
<li><a href="../../tuesday-newsday/index.html">Tuesday Newsday</a></li>
<li><a href="../../rss/index.html">RSS feeds</a></li>
<li><a href="http://review.ucsc.edu">Review Magazine</a></li>
<li><a href="/messages">Administrative Messages</a></li>
<li><a href="http://www.ucsc.edu/budget-update/">Budget Updates</a></li>
</ul>
</li>
</ul>
      </div>

    </div>
    
</div>
        
        <div class="row" id="sprflt">

          <div class="main-content" id="main" role="main">
            <div class="row breadcrumbs"><p><a href="../../index.html">
        Home</a> / 2018 / <a href="index.html">April</a> / Face recognition for galaxies: Artificial intelligence brings new tools to astronomy</p></div>
            <h1 id="title">Face recognition for galaxies: Artificial intelligence brings new tools to astronomy</h1><p class="subhead">A 'deep learning' algorithm trained on images from cosmological simulations has been surprisingly successful at classifying real galaxies in Hubble images</p><div class="article-meta"><div class="article-info"><p class="date">April 23, 2018</p><p class="vcard">
            By
            <a class="email fn" href="mailto:stephens@ucsc.edu"><span class="name">Tim Stephens</span></a></p></div><div class="social-sharing"><span>Share this story:</span><a class="icon icon-twitter--inverted" href="https://twitter.com/intent/tweet?text=Face recognition for galaxies: Artificial intelligence brings new tools to astronomy&amp;url=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share&amp;via=ucsc">Twitter</a><a class="icon icon-facebook--inverted" href="https://www.facebook.com/sharer/sharer.php?t=Face recognition for galaxies: Artificial intelligence brings new tools to astronomy&amp;u=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share">Facebook</a><a class="icon icon-google-plus--inverted" href="https://plus.google.com/share?url=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share">Google+</a><a class="icon icon-linkedin--inverted" href="http://www.linkedin.com/shareArticle?mini=true&amp;title=Face recognition for galaxies: Artificial intelligence brings new tools to astronomy&amp;url=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share&amp;source=http%3a%2f%2fnews.ucsc.edu">LinkedIn</a><a class="icon icon-reddit--inverted" href="http://www.reddit.com/submit?url=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share">Reddit</a></div></div><div class="contentBox"><figure class="lead-image article-image"><img alt="galaxy-images-750.jpg" src="images/galaxy-images-750.jpg"/><figcaption class="caption">A 'deep learning' algorithm trained on images from cosmological simulations is surprisingly successful at classifying real galaxies in Hubble images. <strong>Top row:</strong> High-resolution images from a computer simulation of a young galaxy going through three phases of evolution (before, during, and after the "blue nugget" phase). <strong>Middle row:</strong> The same images from the computer simulation of a young galaxy in three phases of evolution as it would appear if observed by the Hubble Space Telescope. <strong>Bottom row:</strong> Hubble Space Telescope images of distant young galaxies classified by a deep learning algorithm trained to recognize the three phases of galaxy evolution. The width of each image is approximately 100,000 light years. [Image credits for top two rows: Greg Snyder, Space Telescope Science Institute, and Marc Huertas-Company, Paris Observatory. For bottom row:&#160;The HST images are from the Cosmic Assembly Near-infrared Deep Extragalactic Legacy Survey (CANDELS).] <strong>View <a href="https://news.ucsc.edu/2018/04/images/galaxy-images-1500.jpg">larger images</a>, or <a href="https://news.ucsc.edu/2018/04/images/galaxy-images-hires.pdf">download pdf</a>.</strong></figcaption></figure><div class="article-body"><p>A machine learning method called "deep learning," which has been widely used in face recognition and other image- and speech-recognition applications, has shown promise in helping astronomers analyze images of galaxies and understand how they form and evolve.</p>
<p>In a new study, accepted for publication in <em>Astrophysical Journal</em> and <a href="https://arxiv.org/pdf/1804.07307.pdf">available online</a>, researchers used computer simulations of galaxy formation to train a deep learning algorithm, which then proved surprisingly good at analyzing images of galaxies from the Hubble Space Telescope.</p>
<p>The researchers used output from the simulations to generate mock images of simulated galaxies as they would look in observations by the Hubble Space Telescope. The mock images were used to train the deep learning system to recognize three key phases of galaxy evolution previously identified in the simulations. The researchers then gave the system a large set of actual Hubble images to classify.</p>
<p>The results showed a remarkable level of consistency in the neural network's classifications of simulated and real galaxies.</p>
<p>"We were not expecting it to be all that successful. I'm amazed at how powerful this is," said coauthor Joel Primack, professor emeritus of physics and a member of the Santa Cruz Institute for Particle Physics (SCIPP) at UC Santa Cruz. "We know the simulations have limitations, so we don't want to make too strong a claim. But we don't think this is just a lucky fluke."</p>
<p>Galaxies are complex phenomena, changing their appearance as they evolve over billions of years, and images of galaxies can provide only snapshots in time. Astronomers can look deeper into the universe and thereby "back in time" to see earlier galaxies (because of the time it takes light to travel cosmic distances), but following the evolution of an individual galaxy over time is only possible in simulations. Comparing simulated galaxies to observed galaxies can reveal important details of the actual galaxies and their likely histories.</p>
<p><strong>Blue nuggets</strong></p>
<p>In the new study, the researchers were particularly interested in a phenomenon seen in the simulations early in the evolution of gas-rich galaxies, when big flows of gas into the center of a galaxy fuel formation of a small, dense, star-forming region called a "blue nugget." (Young, hot stars emit short "blue" wavelengths of light, so blue indicates a galaxy with active star formation, whereas older, cooler stars emit more "red" light.)</p>
<p>In both simulated and observational data, the computer program found that the "blue nugget" phase only occurs in galaxies with masses within a certain range. This is followed by quenching of star formation in the central region, leading to a compact "red nugget" phase. The consistency of the mass range was an exciting finding, because it suggests the deep learning algorithm is identifying on its own a pattern that results from a key physical process happening in real galaxies.</p>
<p>"It may be that in a certain size range, galaxies have just the right mass for this physical process to occur," said coauthor David Koo, professor emeritus of astronomy and astrophysics at UC Santa Cruz.</p>
<p>The researchers used state-of-the-art galaxy simulations (the VELA simulations) developed by Primack and an international team of collaborators, including Daniel Ceverino (University of Heidelberg), who ran the simulations, and Avishai Dekel (Hebrew University), who&#160;led analysis and interpretation of them and developed new physical concepts based on them. All such simulations are limited, however, in their ability to capture the complex physics of galaxy formation.</p>
<p>In particular, the simulations used in this study did not include feedback from active galactic nuclei (injection of energy from radiation as gas is accreted by a central supermassive black hole). Many astronomers consider this process to be an important factor regulating star formation in galaxies. Nevertheless, observations of distant, young galaxies appear to show evidence of the phenomenon leading to the blue nugget phase seen in the simulations.</p>
<p><strong>CANDELS<br/></strong></p>
<p>For the observational data, the team used images of galaxies obtained through the CANDELS project (Cosmic Assembly Near-infrared Deep Extragalactic Legacy Survey), the largest project in the history of the Hubble Space Telescope. First author Marc Huertas-Company, an astronomer at the Paris Observatory and Paris Diderot University, had already done pioneering work applying deep learning methods to galaxy classifications using publicly available CANDELS data.</p>
<p>Koo, a CANDELS co-investigator, invited Huertas-Company to visit UC Santa Cruz to continue this work. Google has provided support for their work on deep learning in astronomy through gifts of research funds to Koo and Primack, allowing Huertas-Company to spend the past two summers in Santa Cruz, with plans for another visit in the summer of 2018.</p>
<p>"This project was just one of several ideas we had," Koo said. "We wanted to pick a process that theorists can define clearly based on the simulations, and that has something to do with how a galaxy looks, then have the deep learning algorithm look for it in the observations. We're just beginning to explore this new way of doing research. It's a new way of melding theory and observations."</p>
<p>For years, Primack has been working closely with Koo and other astronomers at UC Santa Cruz to compare his team's simulations of galaxy formation and evolution with the CANDELS observations. "The VELA simulations have had a lot of success in terms of helping us understand the CANDELS observations," Primack said. "Nobody has perfect simulations, though. As we continue this work, we will keep developing better simulations."</p>
<p>According to Koo, deep learning has the potential to reveal aspects of the observational data that humans can't see. The downside is that the algorithm is like a "black box," so it is hard to know what features in the data the machine is using to make its classifications. Network interrogation techniques can identify which pixels in an image contributed most to the classification, however, and the researchers tested one such method on their network.</p>
<p>"Deep learning looks for patterns, and the machine can see patterns that are so complex that we humans don't see them," Koo said. "We want to do a lot more testing of this approach, but in this proof-of-concept study, the machine seemed to successfully find in the data the different stages of galaxy evolution identified in the simulations."</p>
<p>In the future, he said, astronomers will have much more observational data to analyze as a result of large survey projects and new telescopes such as the Large Synoptic Survey Telescope, the James Webb Space Telescope, and the Wide-Field Infrared Survey Telescope. Deep learning and other machine learning methods could be powerful tools for making sense of these massive datasets.</p>
<p>"This is the beginning of a very exciting time for using advanced artificial intelligence in astronomy," Koo said.</p>
<p>In addition to Primack, Koo, and Huertas-Company, the coauthors of the paper include Avishai Dekel at Hebrew University in Jerusalem (and a visiting researcher at UC Santa Cruz); Sharon Lapiner at Hebrew University; Daniel Ceverino at University of Heidelberg; Raymond Simons at Johns Hopkins University; Gregory Snyder at Space Telescope Science Institute; Mariangela Bernardi and H. Dominquez Sanchez at University of Pennsylvania; Zhu Chen at Shanghai Normal University; Christoph Lee at UC Santa Cruz; and Berta Margalef-Bentabol and Diego Tuccillo at the Paris Observatory.</p>
<p>In addition to support from Google, this work was partly supported by grants from France-Israel PICS, US-Israel Binational Science Foundation, U.S. National Science Foundation, and Hubble Space Telescope. The VELA computer simulations were run on NASA's Pleiades supercomputer and at DOE's National Energy Research Scientific Computer Center (NERSC).</p></div><div class="social-sharing"><span>Share this story:</span><a class="icon icon-twitter--inverted" href="https://twitter.com/intent/tweet?text=Face recognition for galaxies: Artificial intelligence brings new tools to astronomy&amp;url=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share&amp;via=ucsc">Twitter</a><a class="icon icon-facebook--inverted" href="https://www.facebook.com/sharer/sharer.php?t=Face recognition for galaxies: Artificial intelligence brings new tools to astronomy&amp;u=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share">Facebook</a><a class="icon icon-google-plus--inverted" href="https://plus.google.com/share?url=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share">Google+</a><a class="icon icon-linkedin--inverted" href="http://www.linkedin.com/shareArticle?mini=true&amp;title=Face recognition for galaxies: Artificial intelligence brings new tools to astronomy&amp;url=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share&amp;source=http%3a%2f%2fnews.ucsc.edu">LinkedIn</a><a class="icon icon-reddit--inverted" href="http://www.reddit.com/submit?url=http://news.ucsc.edu/2018/04/deep-learning-galaxies.html?ref=share">Reddit</a></div></div>
            
          </div>
          
          <div class="sidebar" id="subNav" role="navigation">
            
        
          

          
          
<h4>University News</h4>
<ul>
<li><a href="https://news.ucsc.edu">University News Home</a></li>
<li><a href="https://news.ucsc.edu/newsletter/">Monthly Newsletter</a></li>
</ul>
<h4>Other News &amp; Events</h4>
<ul>
<li><a href="https://www.ucsc.edu/tools/calendars.html">Campus Calendars</a></li>
<li><a href="http://www.goslugs.com/" title="GoSlugs.com">Slug Sports</a></li>
<li><a href="http://www.universityofcalifornia.edu/news/">UC News</a></li>
</ul>
<h4>Features</h4>
<ul class="block">
<li class="image-item"><a href="http://magazine.ucsc.edu/"><span class="thumbnail"><img alt="UCSC Magazine Spring Cover" class="portrait" height="195" src="http://magazine.ucsc.edu/wp-content/uploads/2018/03/18-magazine-spring-cover-480x623.jpg" width="150" /></span> <span class="description">UC Santa Cruz<br /> Magazine</span></a></li>
</ul>
<h4>Resources</h4>
<ul>
<li><a href="http://messages.ucsc.edu/" title="Administrative Messages">Administrative Messages</a></li>
<li><a href="http://chancellor.ucsc.edu/" title="UCSC Chancellor">UCSC Chancellor</a></li>
<li><a href="http://press.ucsc.edu/" title="Press Releases">Press Releases</a></li>
<li><a href="https://news.ucsc.edu/rss/">RSS feeds</a></li>
<li><a href="https://news.ucsc.edu/contacts-for-reporters.html">Contacts for Reporters</a></li>
<li><a href="mailto:pio@ucsc.edu">Feedback</a></li>
</ul>
<p><a href="https://securelb.imodules.com/s/1069/index.aspx?sid=1069&amp;gid=1&amp;pgid=761&amp;cid=1722"><img alt="Make a Gift" class="btn no-border" src="https://www.ucsc.edu/images/make-a-gift.svg" /></a></p>
  
          

        
            
            
            
          </div>

        </div>
        
        <div class="main-footer">
          <div class="row" id="footer">
              <div class="footer-left">
                  <img alt="University of California" class="seal" height="84" src="https://static.ucsc.edu/_responsive/images/logos/uc-seal.svg" width="84"/>
<div class="address home">
<div class="location">UC Santa Cruz, 1156 High Street, Santa Cruz, Ca 95064</div>
<div class="copyright">&#169;2018 Regents of the University of California. All Rights Reserved.</div>
</div>
              </div>
              <div class="footer-right">
                  

<div class="social-media">
            
        
        <a href="https://www.twitter.com/ucsc"><i class="fab fa-twitter"></i></a>
            
        
        <a href="https://www.instagram.com/ucsc"><i class="fab fa-instagram"></i></a>
            
        
        <a href="https://www.facebook.com/ucsantacruz"><i class="fab fa-facebook-f"></i></a>
            
        
        <a href="http://youtube.com/ucsantacruz"><i class="fab fa-youtube"></i></a>
            
        
        <a href="http://www.linkedin.com/groups?home=&amp;gid=102708"><i class="fab fa-linkedin-in"></i></a>
    </div>

<div class="links">
            
                            
        <a href="/feedback/index">Feedback</a> 
    </div>

              </div>
          </div>
          <div class="sub-footer row">
              <div class="legal">
                <ul class="legal">
<li><a href="http://academicaffairs.ucsc.edu/accreditation/">Accreditation</a></li>
<li><a href="http://diversity.ucsc.edu/eeo-aa/images/non-discrimination.pdf">Non-Discrimination&#160;Policy</a></li>
<li><a href="http://www.ucsc.edu/about/employment.html">Employment</a></li>
<li><a href="http://its.ucsc.edu/terms/">Privacy&#160;Policy&#160;&amp;&#160;Terms&#160;of&#160;Use</a></li>
<li><a href="http://safe.ucsc.edu">Sexual&#160;Violence&#160;Prevention&#160;&amp;&#160;Response</a></li>
</ul>
                
<p class="page-meta">
    Last modified: April 23, 2018  <span class="check-ip">128.114.113.73</span>
</p>
              </div>
          </div>   
        </div>
        
      </div><!-- /content -->
    </div><!-- /container -->
  </div><!-- /wrap -->

<!-- BLOCK: uniform campus bottom scripts  -->

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5RFHNC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5RFHNC');</script>
<!-- End Google Tag Manager -->

<!-- END BLOCK: uniform campus bottom scripts  -->


        
                    
            
<!-- page bottom scripts start here. -->
<script type="text/javascript" charset="utf-8">
    // Makes a call to the api, then adds html for each response returned
$(document).ready(function(){
  var addHtml = '<div class="content-box recent-news-block" style="margin-top:1.5em;"><h2>Recent articles</h2><ul class="archive-list horizontal list recent-news" id="recents" style="display: flex; flex-flow: row; flex-wrap: wrap;"></ul></div>';  
  $.ajax({
    url: 'https://news.ucsc.edu/latest.jsonp',
    jsonpCallback: 'latest',
    error: function() {
      $('#parent').append('<span>An error has occurred</span>');
    },
    dataType: 'jsonp',
    success: function(data) {
      var artHtml = '';
      var lnkIndex = checkURL(data);
      if (lnkIndex == -1) {
        jQuery.each(data.items.slice(0, 6), function(i, value) {
          artHtml += addCode(i, value);
        });
      } else {
        jQuery.each(data.items.slice(0, lnkIndex), function(i, value) {
          artHtml += addCode(i, value);
        });
        jQuery.each(data.items.slice(lnkIndex + 1, 7), function(i, value) {
          artHtml += addCode(i, value);
        });
      }
      $('.main-content').append(addHtml);
      $('#recents').append(artHtml);
    }
  });
});

// Takes the JSON response and puts it in a string of HTML
function addCode(order, value){
    var artHtml = '';
    artHtml += "<li style='order:" + (order + 1) + "'>";
    if(value.hasOwnProperty("thumbnail")) {
      artHtml += "<img src='" + value.thumbnail + "' width='80' height='80'>";
    } else {
      artHtml += "<img src='http://www.ucsc.edu/identity/images/ucsc-seal.jpg' width='80' height='80'>";
    }
    artHtml += "<span class='date'>" + value.date + "</span>";
    artHtml += "<a href='" + value.url + "?ref=recent' style='display:block; overflow:hidden'>" + value.title + "</a></li>";
    return artHtml;
}

// Checks the first 6 links to see if they are the current article
function checkURL(data){
  var numIndex = -1;
  var url = window.location.href;
  var str = '?ref=recent';
  if (url.indexOf(str) > -1) {
    url = url.substring(0, url.length-11);
  }
  jQuery.each(data.items.slice(0,6), function(i, value) {
    if(url == value.url) {
      numIndex = i;
    }
  });
  return numIndex;
}
</script>
<style type="text/css">
    .horizontal.recent-news li { display:block; }
</style>
<!-- page bottom scripts end here. -->
  
          
        
        

</body>
</html>